Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-21 17:10:09

Spansion S29AL016M TSOP48

Please can someone help me, ive been trying for a long time now to erase the above tsop flash chip.

Im using the W4.5 with sivava 16bit adapter, I can read the chip ok but when I come to erase it, it stops at about 2.6 seconds and always says ‘’erase completed by check DQ7’’ and fails on Blank Test ‘’Device Not Empty $004000’’ but when i look in the buffer all i can see is FF's

I’ve read through the forum for this chip and tried lots of different settings to no avail.


I can read/erase/blank test/write/verify any other tsop 48 ok its just this spansion im having trouble with.

Ziff socket test H/W is all ok, DSW’s are all ok, im really stuck with this chip and just don’t know what to do anymore.


Device 29lv160 does not detect the chip I have to use 29f160:

Manu:                    0x0001      AMD
Device Code:            0x2249 Am29LV160B



Any help would be highly appreciated.

TIA
OE

Re: Spansion S29AL016M TSOP48 cant erase?

By: EZo - 2008-02-22 17:55:11

What SW do you apply ? What pcb4.5c mode (pcb45 or pcb3b)settings ?

Re: Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-22 18:37:40

thx Ezo,

sorry thats the only thing i forgot to say,

i use epr097ja for all my TSOP's in willem mode.

im not sure about the pcb4.5c mode (pcb45 or pcb3b)settings i dont see them anywhere in the software


regs
OE

Re: Spansion S29AL016M TSOP48 cant erase?

By: EZo - 2008-02-22 19:24:48

Quote:
im not sure about the pcb4.5c mode (pcb45 or pcb3b)settings i dont see them anywhere in the software

It is programmer option, not SW.
0.97ja used, you have to set 2 jumpers in position pcb3b  on programmer.

Re: Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-22 19:34:30

ok thx,

which jumpers are they? and where about on the willem 4.5 are they located??

Re: Spansion S29AL016M TSOP48 cant erase?

By: EZo - 2008-02-22 21:04:54

Sorry, my misunderstanding. You have Willem 4.5 .
You can use built-in tsop48 socket to program chip in 8 bit mode.
Set voltage DSW 3-ON (3.3V), DSW12 block according picture in SW, jumpers Vpp and 29F off.
For use with sivava 16 bit adapter - DSW 3-ON (3.3V from programmer), set jumper on adapter (OPEN-3.6V). Jumper A18/A19-Vpp in position Vpp. Connect wire-cable A19 and A20 between programmer and adapter , pins are located differently on boards.
Adapters jumper block according picture on board (29Fx00)  

Re: Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-23 00:03:07

thx ezo ill give those methods a try later.

regs
OE

Re: Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-27 22:09:57


well ive been pulling my hair out with these darn Spansion S29AL016M LOL

ive tried both methods you recomend Ezo and i still cant erase the chip,

when i try to erase it says ‘’erase completed by check DQ7’’   and fails on Blank Test ‘’Device Not Empty $008000’’ or erase fails if i use diffrent device type although ive got correct ID.

i can now read the chip and actually see in the buffer that it is erased up to $008000 then after that the chip is still full of data.


ive read that these chips may be write protected although im not totally sure.

any more idea's Ezo please?

thx again for your time.

regs
OE

Re: Spansion S29AL016M TSOP48 cant erase?

By: EZo - 2008-02-28 14:35:59

Quote:
ive read that these chips may be write protected although im not totally sure

Before your chip was empty (first topic, buffer 0xFF). I don't think protected.
Quote:
i can now read the chip and actually see in the buffer that it is erased up to $008000 then after that the chip is still full of data.

Check chip pins (straight, clear). Check chip pins location in socket, small shift required to fit pins exactly.
Quote:
if i use diffrent device type although ive got correct ID

What device selected in SW ? Try 16bit > 29F160.

Re: Spansion S29AL016M TSOP48 cant erase?

By: one_eye - 2008-02-29 00:45:20


first topic was when i was using 16bit adapter and it wouldnt read the chip properly,

now im using the built in TSOP 48 on the W4.5 this way i can read the chip fully but cant erase fully.

when i select device 16bit > 29F160 i get correct 'ID/Manu' and erase goes all the way to the end but then says ''error erasing chip''

the only device that allows me to erase is  16bit > 39LF/VF160 but then fails on blank test ‘’Device Not Empty $008000’’

the pins on the chip are 100% ok and good contact, i also always check for fragments of solder bridging legs but thay are all perfectly clean.

i do a lot of tsop repairs/reflashing and are always ok, i can do 30-40 Intel chips without a problem but this spansion chip is proving very dificult.

regs
OE